Salty Old Man Sucks at Video Games - Kingdom Come Deliverance

The place to discuss your favorite toys (action figures, dolls, building blocks, etc.), board games, and video games, as well their related industries and related news.
Post Reply
User avatar
Posts: 1935
Joined: Fri Nov 04, 2016 9:16 pm
Location: Canada

Salty Old Man Sucks at Video Games - Kingdom Come Deliverance

Post by Arkrite » Mon Jul 01, 2019 4:52 pm

Warning: Contains profanity, and a person who sucks at video games. You've been warned. Twice on that last part.

Heard great things about Kingdom Come Deliverance.
Buy it on steam for 20 bucks.

Start game.

Blurring so bad I can't turn without getting sick.
Stop game, go into settings, turn off motion bluring.
Still weird.
Stop game, go into settings, increase POV.
Try to move around.
Still bizarre.
Switch to controller.
Great, this is much better.

Until I get the first pop up window and holding B doesn't do anything.
Have to hit escape on keyboard to get out of window.
Why isn't B working? It works when I am in menus.
Cool, now I wander out talk to my Dad, get a quest to retrieve some stuff, get basically roped into a fight (suspect you can get around it, but involves knowing more than I do) but I don't know how to fight.
Ten minutes later I am victorious. I don't know how, but somehow I won.

Get confused about my goals, wander around getting hungry. Pick up items to retrieve, go to vendor. Lose rep when I can't buy from him because I have no money and he won't buy the items I got.
Finally discover journal, learn I'm supposed to return it to my Dad.
Lose rep with Dad for completing quest.
*sigh* Thanks, Dad. :/

Have first sword tutorial, okay, this could be fun. Very short. Back to fetch quests.

Completely fetch quests and, oh @$*#, Mongolians! Okay, first bad guy arrives. It is time to teach him that messing with my town is... oh, I'm dead.

Huh, lets try that again and... why don't I have my sword?
Okay, go into inventory and equip it. Cool. And back to fight and... dead. Probably had something to do with me STILL attempting to pummel him to death with my fists.

Okay, go into the controller settings to learn how to draw sword.
There is no command to draw sword on controller.
Have to use the keyboard to draw sword. Oh good grief -_-;

Okay, I have learned how to draw my stupid sword... wait, no, I have learned how to draw this mastercraft sword, so now it's Go Time!

Time to teach this punk a lesso- and I'm dead again.

Okay, is probably realistic. I'm a farmboy with no training in sporty clothes, vs trained soldier in armor... but I'm already not having much fun, so this just pisses me off. Why not just move forward in cut-scene rather than force me to run after FINALLY giving me a weapon? If you didn't want me to fight: Do not give weapon!!!

Screw it, I refuse to go down without hurting this guy!
Fifteen deaths later I conclude that the combat system is bull#*$%. Nothing I can do will get me more than one lucky hit before the bad guy chains seven hits on me.
Again, realistic. Again, not fun.
This is an issue, I haven't had fun since this game started.
Common argument, games aren't supposed to be fun, they're supposed to be entertaining.
Well, I'm not having fun, and I'm not entertained. Good show.

Okay, give up and try to run. To run I hold down B and... uh... I'm not running.
For some reason game doesn't register me holding B button.
God dammit.
Waddle off the side of the cliff, find baddies attacking Theresa the cute girl who wanted me to nail her- err, wanted nails. Time to be the big damn hero! I stab one in the, oh @$#*, these guys are all in heavy armor.
Okay, sorry girl, you're on your own, I waddle to the horse, get on and am promptly filleted by the bad guys since I can't run.
Then the horse refuses to run.
Then I'm pulled off the horse and murdered.


I am two hours in and I am pissed off. Controlling on keyboard is a nightmare, but controller lacks functionality, plus doesn't work right.

The way the game starts off puts me into multiple no win situations while teasing me with sword combat. If I wasn't supposed to fight:

1) Don't train me on how to fight until after tutorial section.
2) Don't give me a weapon
3) Don't show my family being slaughtered right in front of me after training me to fight and giving me a weapon!

Honestly I don't know if this game is bad, but the design isn't doing it any favors so far.

Go online looking for solution to controller issue.
Get told for a full half an hour that I'm an idiot, I can't get a date, I am hardly a man, that I need to "get gud", and that I should just use a keyboard.
No sure how that helps me fix my controller problem, but now worrying about the low self esteem of the people playing this game that their response is to try to make me feel worse about my life.
Didn't I start doing this because I already felt bad and was hoping to cheer myself up?

#*$# it, fine, lets's try the keyboard again. I mean, having to relearn all the controls after being at the end of the tutorial won't be an issue...

Spend another half an hour banging my head against windows in steam.
Turns out that the default setup in the game is to... not... have the buttons set up.

Okay, whatever, back in the game. I can now draw my sword, sheath my sword, and run!

Run away from immortal jerkass 1, find Theresa the Cute and interrupt the attempted gang assault by sneaking up and OH GOD THEY SAW ME RUN!!!
Uh... auto-locked onto one of the bad guys, oh right I can just hold B to turn off the lock and... no, it just keep locking on a new guy, I can't run, and I'm dead again.

How do I type a furious emoji?
I'm not even past what SHOULD be the half hour point for this game and I'm losing my god damned mind because of bad quest design and horrible controls.

Now what? Do I attempt to do it again, with the keyboard and mouse or continue punishing myself with the controller?


I don't feel like fighting to make the controller work. Full controller functionality my ass. :P

Go back to Keyboard and Mouse. Okay, this might work.
Run down and, ugh, old man hands cramping from holding down the shift button while moving.
Get down to the baddies and, god damn, are they psychic? They notice me even when I come up behind the building.
Fine, run to horse and hit the E button which... brings up a horse menu?
Promptly murdered.

#*$# this game.

Run back down.

Enemies notice me because I whistle while trying to crouch. God damn old man hands.
Run for horse, notice prompt saying Mount is the X button.

Get on horse attempt to run, soldier seem to be superhuman in running speed, pull me off horse.
Fumble to jump over fence, discover their horse like speed is matched by horse like jumping.
Wonder if they'll join the Horse Jumping competition or the horse races first.
Oh, and they murder me again by the time I realize I can't jump a second time, and before I can more than draw my sword.

#*$@ this game.

Each time I die I need to start over from the checkpoint because I can't save without using a "Savior Schnapps". Love the name, hate the mechanic. Is there to prevent people from save scumming.
Stop telling me how to enjoy the game. Because so far it's not working your way, dammit!

So every time I fail I have to run down to my next murder point.

This is getting miserable and I haven't even passed the tutorial. What am I at now? Still two hours? Must nearly be three.

Respawn. No volume.
Run back down, whistle again because of course the whistle button is next to the god damn sneak button.
Run to horse, run away from assholes instead of trying to fight or do anything fun.

Jump into cut sequence where volume returns, huzzah, and I'm shot in the leg with a bow for daring to follow the story.
Okay, at least we can skip to the next part of the- oh god damn it, now it's a horse chase.

And the volume is gone again.

Fine. I draw my sword and, huh, the hose seems to be following the path so I guess I just fight?

Oh god, the horse ran into a wall, it's not on rails. Okay, well, I'm getting slaughtered now (more than before, those archers are murdering me), so I turn and... now I'm stuck in a river on my horse. Okay, get out after three minutes of being unable to go up the sides of the creek.
Onto the wrong side.
Back into the creek.
Two minutes later I'm on the right side, but I'm still losing life.
Assuming it's archers, I can't see anybody, and my volume is still busted. Appear to be going wrong way now, going back towards quest marker. Text appears on screen telling me I'm going the wrong way.
And I'm dead again.
Turning off game to see if restarting brings back god damn audio.

Thankfully this time the game starts after the cut-sequence where I got arrowed hard.
This section is supposed to be nerve wracking and gripping as you flee, praying to escape before you are brought low by some serious damage.
Since I've already died about thirty times I'm just frustrated, grinding my teeth as my health is slowly whittled down as my horse randomly stops running. Because I expect to die and I really don't want to do this any more.

Finally make it to the next town just before I scream in frustration and my health completely disappears.

But it's okay, I've made it, it's time for... slow drawn out conversations and the discovery that not eating or sleeping for long periods of time make the entire world blink in and out of existence.

Holy crap, is that what hunger does to normal people? It just makes me irritable.

Finally I get sent to bed, the Lady of house shows up and... oh my, do I actually get to interact with people?!
This is the first bit of entertainment I've had in god knows how long. A couple quick responses later and she's gone, I'm on the wall and stuck... waiting?

It took me nearly five minutes to realize I was supposed to just use the wait option.
Can I PLEASE do something now?

Okay, need to go bury my folks.

Except they won't let me leave the castle, because it's dangerous.

Jump the fence. Caught immediately by a guard I passed who can't know I'm on the run.

Managed to talk him into letting me go. He asks me to give him a shove and he'll pretend he fell over.

Okay, give him a little punch.

He goes hostile and murders me.

.... Okay, so push and punch aren't the same. I will note that there is no push button.

Respawn, jump off the castle into the moat, again, run into a small rock I can't jump over. Forced to do Skyrim climbing (read, jumping on side of mountain) to avoid guards. Randomly walk far enough away, fast traveled to the town. And a god damn rain storm. Was sunny seconds ago.

See the coal burner, one of the NPCs from my first quest, dead on the ground. Poor bastard.

Then twenty feet further up the road I see... the coal burner... still dead... Uh... So was that supposed to be his twin brother the coal putter outter?

Ugh. God dammit guys, don't reuse the assets for special characters.

Wander into town looting pretzels off of two day old corpses that are being soaked to the bone in rain.
Best plan ever.

Sadly more fun than I have had for a while.
Killed a bandit. Turns out these guys aren't so tough when they're not wearing plate mail and carrying shields.

Spot another bandit looting a body. My character demands he stop, and to no one's surprise the bandit runs. I chase. Finally catch up and attack him with my sword, he... surrenders?
Huh, okay, so what is my reward for catching him?
Nothing. I wasn't supposed to chase this guy. For five minutes.

God dammit, game.

Okay, so that wasn't a quest, it was ambiance, how about a "good riddance" or something to let me know?

Five more minutes of running to get back into town.

Find the bailiff. "He died with a sword on his hand. He didn't run. Like me."
Bitch, are you for real?!?!
I died like thirty times, and at least half of those was with a sword in my hand!
... you know, after I figured out how to pull it out.
Bailiff ain't got shit on me!

Found my girlfriend. Yup. She's like... super dead. Way more dead that normal.
... Okay, she's just normal dead.
Loot her body for the ring I gave her. For a keepsake.
Also took her pretzel.

For a keepsake.

Continue looting pretzels all the way up to my parents.
Music swells as an adventurous theme starts belting out and you can practically hear the conductor screaming "Shit, it's supposed to be sad, cut the music! Cut the music, dammit!"

Suddenly the next entire cut sequence is accompanied by nothing but rain.

Well, time for my next heroic adventure. Finding a shovel.
To bury my parents.

... Fuck this game is dark.

So the cut-scene ends and I pay my respect in the only way I can think of.
I steal the pretzel off the body of my parents.
I shall cherish it always. Or I would, it kind of went into a stack of like thirty of these things.

Oh screw it. I plan on binge eating later to kill the pain.

So I'm distracted by the only sound that isn't rain. The barking of a dog. Well, either the dog is a hint on where to go, or I am about to be eaten alive by wild dogs.
I'm betting on that second one, but it can't be worse than what I've dealt with so far.

So I wander on over... and discover that following the sound is a bad idea. It leads you to the left of where you were supposed to go. I had to do a full loop around the place before it set off the cut sequence. There's a dog defending it's dead master.
And hey, attacking the dog with a shovel, it's my old friend Zeb... zyb... Coach Z. Coach Z is busy robbing the dead.

For shame. How dare he do such a thing. Do you have no honor? Do you have no respect? Do you have any pretzels?
I ask him how his girlfriend (Theresa, the one that I saved earlier by whistling) is. He tells me that he hopes somebody attacked and assaulted her.
Jeez. Ooookay, so I ask him how he escaped. Says he ran then calls me a coward.
Uh-huh, so I ask for the shovel, he demands my sword in trade. The sword my father made.

Seriously, this was one of my closest friends only... oh god, has it been over three hours now?

Anyways, I call him a cad, he drops the shovel and runs screaming about how I will regret this.
Ha! I think not! I chase him down and... god damn, is he part road runner? He runs over twice as fast as I do, he's out the gate before I can even get halfway across the courtyard.

Oh well, I'm sure nothing bad will come of letting him live.

So something bad comes of letting him live, he leads a bunch of well armed and armored bandits right to me. Okay, first honest one on one fight that the game sets up.
I attack, he blocks. No damage.
He attacks, I block. He bludgeons me anyways though the guard and I go down like a soggy bitch.

Oh thank god, for a moment there I thought I'd actually get a heroic moment, or a fair honest fight.

So he takes my father's sword, makes a long speech about how nice it is while I flop around on the ground like a magikarp, and proceeds to try to kill me.
Yes! Strike me down. Give in to your hatred.

So Theresa appears out of nowhere, in her best Superman pose, in the rain, and declares "Bitches leave".

The goons laugh.

Then the Knights from the place I escaped from come running in to save me.

So... how did Theresa get here? How did she find the knights? How did she get in front of said Knights that she obviously knew were coming? Will she protect my pretzels?
And is the dog okay?

Oh thank god, the dog is okay.

So after nearly four hours I get the opening sequence showing my broken and battered body being carted around by Theresa, up to the castle, into the castle... out the other side of the castle?
Oh whatever, I don't care anymore, at least I have a dog now.
And the cut sequence ends with Theresa revealing her unholy leader/Uncle... Wait, is that Chef Boyardee?

... This game is so fucked up.

So the game starts back up, and I'm obviously in a nightmare. I can tell because the game is still running, I'm surrounded by the unstoppable soldiers from the beginning of the game, and I can't draw my sword. So I have to punch them to death. Which I would, except they're the unstoppable soldiers, and apparently even in my dreams I can't punch five times without losing my breath and gasping like a beached whale.

So I solve it like I solve all my problems.

I run away like a little bitch.

Then I wake up to Theresa. She explains what happened. All mysteries are revealed.
She was trying to distract the bandits when she appeared, but had no idea anybody was coming. Or any plan on what to do after they'd been distracted. Apparently she "just wanted to die".
... That's... stupid. The big glorious rescue was just massive amounts of coincidence. Because it looks cool in a cut scene.


Can I do anything fun now? Like not getting punked like a bitch?
God dammit game.

So I meet Chef Boyardee, he has a quest involving robbing the dead and god knows what else. I swear this guy is going to sell his niece into prostitution. This bothers me because she's the only living character I like at this point.

Because the dog is now missing.

So I ignore his ass and go looking for a fight. Sadly my spare axe (the only weapon I've found so far) was looted off my body, making sure I'm unarmed and not about to go have fun. But I still have hundred of pretzels to remind me of my home town.
So I run.
And run.
And run.
And run.
and... eventually I run into a blockade. Well, actually it's like a tiny log and four branches in the road. I can't jump it though, so hey, who am I to judge. So I figure, okay, one or two bandits, no problem.

Four guys in full armor with shields and swords.

Okay, well, joke is on them. I'm wearing no armor and there's a river right there, I'll swim across. :D

So at this point I learned I can't swim. :roll: I backed myself into the invisible wall of water, and they cut me to shreds.

Burn in hell game.

Decide to try again because: Masochism.

Go with the main story-line, decide to pick plants on way to castle because it's apparently the only task I can do without getting killed immediately.
I'd make a great 8 year old girl.

Game forces an animation every time you pick a single plant that takes three to four seconds.
Being an 8 year old girl sucks. But not as much as being the main character in this game, so I keep picking flowers.

Get to castle, get abused by nobles who while largely being right about me being useless, can't seem to decide if they like me or hate me. So they agree to like to hate me and offer me a job. Go meet the trainer at the training ground!

Get there.

Oops, it's currently night right now. Even though I ran directly from waking up to the next story plot point. Five minutes ago.

Okay, so I can wait around for a day, but it'll hurt my stamina. So I fast travel to the other side of the castle to get to the camp to sleep for the night.

It gives me an informational pop up about criminal acts. I have no idea why.

Go to bed.

Wake up to a guard who informs me that I've been seen walking around at night.
He sends me to fucking jail.

... The hell?!

Okay, so miss a day of gaming because... I walked to camp at night.

God damn this game.

So I get out of prison, a grim and bitter man... who has apparently been starved, not allowed to sleep, and now I have massive debuffs to all of my physical stats.

Because I WALKED to CAMP at NIGHT.



Fuck this game.

So now I need to return to camp, find some food, and sleep. So I can go back to the training area. And not be beaten to death in three seconds of fighting.

So I can actually have some fun in this game.

... Seriously, why am I still here?

Oh, right, because I have had a single fair fight in this game and I don't want to give up on it until I've had a chance to actually fight in some battles that aren't curb stomp battles with me as the one and only victim.
I want to give this game a chance to shine, dammit.

Leave prison. I'm praying that I'm allowed to leave and that this isn't considered a damned escape attempt.

Tempt fate, fast travel back to camp. It's 9 in the morning, but my character is falling asleep on his feet. Fine, sleep for the next 24 hours.
Not allowed to.

Can only sleep 12 hours, which puts me back at night and WE KNOW WHAT HAPPENS AT NIGHT!!! :evil:
Can't go back to sleep. -_-

So how do I wait until morning now that I can't sleep, and not sleeping will result in exhaustion which will make doing things during the day hard. Can't go out at night because you'll be arrested for walking, or killed by... anything(?) in the dark.

Okay, so I've heard you can knock out guards and steal their stuff.

Time to try.

Hit the knock out button. Guard just kind of... doesn't get knocked out. Challenges me to fist fight. Other guards come and stab me to death for crime of having fist fight with a fully armored guard who obviously thinks this is funny. My punches barely hurt unarmored people.

Also guards still super capable of just blocking/ignoring all of my punches.

I die horribly.

Respawn, knock out guard successfully this time.

HA HA HA! Now I have the armor and... oh god, carrying nothing but the armor and weapon is too heavy for me. I'm overloaded just wearing the armor. I have nothing else in my inventory, and I'm over burdened. I am the son of a blacksmith, and a peasant who has to work manual labor for a living.
This is literally the myth most people have in their head, that armor is so heavy you can't actually move in it. And this is supposed to be a realistic game that avoids those specific tropes.

So now I'm in stolen gear, so I decide not to go back into town dressed as a guard. Call it a hunch, but if walking at night is a criminal act, I can only imagine what pretending to be a guard in stolen armor is considered.

I get lost for a half an hour wandering the world waiting for somebody to come fight me.

Dump everything I have, buy a feat to increase my carrying capacity and fast travel to the (now destroyed) starting town.
Within a minute I am spotted by a guy in full armor with a sword and shield.

I draw my weapon, and immediately get informed that I don't have the stats to use this equipment so I'm at a massive disadvantage.


So I'm killed almost instantly, even with the armor. Three hits.

Respawn back in time to before I stole the armor, get to do training after waiting, then sleeping, then waiting, then sleeping, then having low energy and no food.


Training is okay.

Promptly put into archery contest after accidentally putting my bow away while trying to draw it. This means I get no practice.
Promptly fire arrow everywhere but my own target because there is no aiming reticle, making archery even harder than it needs to be.

Get stuck in an archery contest with douchebag noble who challenges me for money. Like an idiot I auto accept because... well, how dare I have options.
So I miss.
He wins.
Then he challenges me to a sword fight.
So I use everything I've learned to... barely annoy him. I hit him more times than he hit me, not counting blocked attacks, but he hasn't a mark on him.
And he kicks the unholy shit out of me.
Demands more money, treats me like dirt, and walks off.

In a fit of spiteful gamer rage I try to gank him from behind.
Oh, he's immortal and you aren't allowed to attack him.

Okay, I finally got to do sword fighting, I'm not having fun.

Fuck this game.
I quit.

And I'm taking my pretzels with me!

Posts: 1975
Joined: Fri Nov 04, 2016 8:27 pm
Location: Connecticut USA

Re: Salty Old Man Sucks at Video Games - Kingdom Come Deliverance

Post by Shock » Mon Jul 01, 2019 6:57 pm

Try decaf next time :P

Non-asshole version of post:
Originally I hoped Kingdom Come Deliverance would be a Skyrim type of game. I was quickly educated on that.
I've seen a couple of videos where it looks like a neat game. But it also looks like a lot of work. You have to eat, drink, sleep, wash, maintain weapons, etc. Just... lot of work. The Slavs are not a happy culture.

Sucks you had such a miserable experience. I probably would have given up long before you did

User avatar
Posts: 1935
Joined: Fri Nov 04, 2016 9:16 pm
Location: Canada

Re: Salty Old Man Sucks at Video Games - Kingdom Come Deliverance

Post by Arkrite » Mon Jul 01, 2019 9:18 pm

I was determined to get my twenty bucks worth ;~)

Posts: 2284
Joined: Fri Nov 04, 2016 8:08 pm

Re: Salty Old Man Sucks at Video Games - Kingdom Come Deliverance

Post by Spectrum » Mon Jul 15, 2019 5:56 pm

I'm with Shock on this one. I would have given up much earlier. I have given up much earlier. I'm generally realizing that I don't like the modern state of gaming.

Tired of adding cost of grief of playing the game to the cost of game.

Still, better you than me :)

Thanks for a fun read of your pain and suffering.
We rise from the ashes so that new legends can be born.

Post Reply